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2 Introduction
Quoted from CURL WebPages (http://curl.haxx.se/ ):

“Curl is a tool for transferring files with URL syntax, supporting FTP, FTPS, HTTP, HTTPS,
GOPHER, TELNET, DICT, FILE and LDAP. Curl supports HTTPS certificates, HTTP POST,
HTTP PUT, FTP uploading, kerberos, HTTP form based upload, proxies, cookies, user+password
authentication, file transfer resume, http proxy tunnelling and a busload of other useful tricks.”

Here in this document we explain how to use CURL as a dIl library in your Visual Studio' C/C++
Project. There are many ways to use CURL but here we explain the simplest way with the
minimum files needed from CURL. Once you build and run this simple application you can
explorer other features of CURL and add more functionalities to your project.

The document explains how to configure different parts which seems, by reading news groups,
many people have similar problems with using dll files and configuration of Visual Studio and curl
libs. So now that [ have solution to those problems why not putting everything in a document so
that other people don’t put same amount of time to figure out solutions to those problems.

! Visual Studio Version 6.0 has been used in this document but any other versions should be the
same.
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3 Installation of libcurl

You need to download the latest CURL code and unzip it to get the libcurl source codes for
building the dll and lib files.

3.1 Download the right code
Download the latest version of CURL from the download page of CURL:

http://curl.haxx.se/download.html

For this document I have used the version curl-7.9.6.zip

Unzip the zip file to a temporary directory. It will give you following directory structure:

{:I docs
r:l include
=1 lib
{:I packages
{:I src
{:I tests

For our application as we want to use the dll file and on Windows (PC) then we are only interested
in the directory called “lib”. You can look at other directories and files later once you build your
first application. You will need the directory “include” too as all header files are inside this
directory.

3.2 Compiling libcurl

Go to lib directory and double click on “curllib.dsw” which is the Visual Studio Project file for
curlib. It will start the Visual Studio with correct configuration and settings. Of course you need to
have Visual Studio installed on your machine.

Once the project is opened click on Build button to compile files and build the project:

Build

This will compile all files and build the libcurl.dll file for you:

Compiling...
base64.c
connect.c
cookie.c
Generating Code...
Linking...
Creating library Debug/libcurl.lib and object Debug/libcurl.exp

libcurl.dll - 0 error(s), 1 warning(s)
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Now if you look at the directory curl-7.9.6\lib\Debug you will find 2 created files, which we are
interested in:

e libcurl.lib
e libcurl.dll
For creating our application the minimum we can use from CURL is these 2 files plus the include

directory. So now you can close your Visual Studio Project and workspace as we are going later to
create our own application
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4 Using libcurl library (libcurl.dll) in your Visual Studio Project

You can create any file structure and choose any application name that you want. But if you
choose the same structure as our example below it’s easier to follow all examples here and
compare our figures with what you get in case you get problem.

4.1 Preparing the file structure for this project
Create following file structure in your C drive:

C:\Project\libcurl

Cdinclude File Folder
Clib File Foldsr
[ visualStudia File Folder

Where you create directory libcurl inside C:\Project and there you create 3 directories. Directory
include is an exact copy of the include directory from curl-7.9.6\include so copy the directory
include from the unzipped curl files to C:\Projec\libcurl.

If you look at this include directory you will find some make files and one subdirectory called curl:

EH:I libeurl
E EH:I include
i a aurl

You can delete all make files and keep only header files if you want:
%curl.h 27KE C Header File

%easy.h 3KB C Header File

%mprintf.h 3kKB C Header Fie

£ rrulti.h 7KB C Header File
%stdcheaders.h 2KB C Header File

%types.h 2kKE C Header Fie

Inside lib directory you need to copy those 2 files which you built in step 3 it means following
files:

e libcurllib
e libcurl.dll

So now you have all header files in C:\Project\libcurl\include\curl and 2 files in
C:\Project\libcurl\lib. That’s all you need from CURL and now you can start building your
application to use these files.
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4.2 Creating a simple Hello World application

You can create any kind of application you want but here we create a simple one to show how to
use libcurl.

In Visual Studio go to File -> New -> Projects and choose “Win32 Console Application”:

vew 2|

Filez  Projects | Work spaces I Other Documents |

] &TL COM Appwizard Project name:

¢ | Cluster Resource Type Wizard IM_'.JAppIicatiu:un
gi| Cuzton Appiafizard )
‘=1 Database Project Lagatiot:
B4 DeyvSudio Add-n Wizard |E:'\F'F|EIJEET SLIBCURLAWISA J
B |S4P Extension Wizard
= | b akefile

#m P Activer Contralwizard
8] MFC Appiwizard ()

B AP Appiwizard (exe]

'} Utility Project I j
A|'win3zZ2 Application

¥ Create new workspace
) fdd o curent workspace
I" | Dependency of;

\pplication
|%] 'win32 Dynaric-Link Library _—
%] 'win32 Static Library Flatformns:
|W|n32

(] I Cancel

For Project name choose “MyApplication” and for location choose the
C:\Project\libcurl\VisualStudio:

Directory name:

IE:"'.F'HDJEET"-.LlBEUHL"-."-.-"lSLl.l‘i".LSTLlDlm Cancel |
[= c:h ;I Metwark. .. |
[= PROJECT

[= LIBCURL
B= VISUALSTUDIO

=
Drrives:

= o CDRIVE |
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Click OK and when it comes to next window choose “A Hello World Application” part:

Win32 Console Application - Step 1 of 1 e b

What kind of Conzole Application do pou
want bo create?

= An emply project.

& simple application.

& "Hello, Word!" application,

" An application that supports MFC,

< Back et | Finizh I Cancel

Press “Finish”, it will create all needed files for you and create a directory called “MyApplication”
under C:\Project\libcurl\VisualStudio.

Once it is done, you can click on the left panel on “FileView:

‘
B8 Classhiew | Filetigw |

A

To see your main application called MyApplication.cpp:

aa

14l

_Wu:urkspau:e ‘Muspplication’ 1 projectz):
El MyApplication files
=43 Source Files
© e [#] Mybpplication.cpp
Std&fx.cpp
Ela Header Files

(£ Resource Files
o Feadte.tut

Using libcurl in Visual Studio

9 (15)



Using libcurl in Visual Studio

Prepared: Rosso Salmanzadeh 04/25/2002

Double click on MyApplication.cpp it will open the source code for your “Hello World”

Version 1.0

application:

) Sl dR-||leex B

| I'~ MyApplication.cpp @ Defines the entry point for the console application.
o

#include "stdafz. h"

return 0;

printf{"Hello World!~n"});

int main{int argc, char#* argv[])

Click on “Build” button to compile and build all files.

Build Run

Hello World?
Press any key to continue

You will see a debug directory is created:

4

El_l include

_I My application
- ;I DE':ILIQ

Where the EXE file of your application (MyApplication.exe) exist:

EMy.ﬁ.pplicatiun.exe 169 KB
T rvapplication, il 168 KB
B vy application. obj KB
B vy application. pch 209 KB
[ Myapplication, pdb 337 KB
B stders.obj 3KB
2 vea0.idb 33 KB
T veen,pdb 52 KB
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4.3 Adding libcurl to your project

Now that our environment is set up we can add libcurl to our application. The easiest way is to
replace the “Hello World” code with a simple CURL client code from following site:

http://curl.haxx.se/libcurl/c/example.shtml
We choose one simple one it means the simple.c:

http://curl.haxx.se/Ixr/source/docs/examples/simple.c

We copy and paste following lines and replace the Hello World code with this code. Note that we
need to keep #include “stdafx.h” here and for testing we put the URL of www.cnn.com for our
request:

#include "stdafx.h"
#include <stdio.h>
#include <curl/curl.h>

int main(void)

{
CURL *curl;
CURLcode res;

curl = curl_easy_init();

if(curl) {
curl_easy_setopt(curl, CURLOPT_URL, "http://www.cnn.com/");
res = curl_easy perform(curl);

/* always cleanup */
curl_easy_cleanup(curl);

}

return 0;

}

Before being able to compile you need to take some steps which are to include header files to your
project and include the dllI file to your project

These steps are explained below.
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431 Adding *.h files to include path

Go to Tools -> Options -> Directories -> Show directories for Include Files:

options 2 x|

E ditar | Tabs | Debug | Compatibility | Buld  Directories | '3 EE

Platfarm: Show directaories for:
[afini32 =l |include files =l
Directories: L R

C:\Program FileshMicrosaft Wisual Studic'WCIgWMCLUDE
C:\Program FileshMicrosaoft Wisual Studic' W CIFWAFCAMCLUDE

ak. I Cancel

IE:HF‘quram FileghMicrogzoft Wisual Studin'WCIBATLAMNCLLIDE
| E

Click at the end of list to open the dialog window and choose the directory

Click
Here

C:\Project\libcurl\include. Note that you shouldn’t choose C:\Project\libcurl\include\curl where all
header files exist but the C:\Project\libcurl\include because many CURL files are using something
like "#include <curl/curl.h>" with prefix curl/ so you need to choose the parent directory for your

include to work:

options 2 x|

E ditar | Tabs | Debug | Campatibility | Build  Directories | 't EE

Platform: Show directories for:
[win32 =l |Include files =l
Directaories: . e &

C:\Program FileshMicrosaft Wisual Studio\WCI3WMCLUDE
C:\Program FileshMicrosaft Wisual Studio\WCIFWFCAUNCLUDE

C:\Program FileshMicrosoft Yisual Studio\WYCIBATLAMCLUDE
IE:HF‘H QJECTSLIECURLNISImEE]N]S

(] I Cancel
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Adding libcurl.lib to library path

Version 1.0

Change “Show Directories for:” from “Include files” to “Library files” and add even the path to

the library file (it means to libcurl.lib):

Editor | Tabs | Debug | Compatibility | Buld  Directonies | g EE

2|

Flatform: Show directaries far:
[win32 | |Library files =l
Directaries: FE A S S

C:%Program Files'Microzoft Wisual StudiohCI84LIE
C:%Program FilesWMicrozoft Wisual StudiotWCO8MWMEFCHLIE

=

IE:'xF'FE OJECTALIBCURLALIE]

Cancel

o ]

Adding libcurl.lib to list of libraries

Now you need to tell Visual Studio to link your program with the libcurl.lib. You do it by going to

Project -> Settings -> Link -> Category (General) and adding libcurl.lib at the end of list of lib
files in the “Object/library modules” part separated with white space:

Project Settings

Settings Far:

Win32 Debug =]

-- tudpplication

General I [Debug | C/C++  Link | Hesaurcé EE

j Rezet |

Categary: IEeneraI

COutput file name:

IDebug.a'M_l,lApplication. EHE

Object library modules:
|32.Iih oleaut32. b uwid.ib odbc32 b odbocp32. lib ([ag=mrifis]

¥ Generate debuginfo [ lgnore all default libraries

v Link incrementally [ Generate mapfile

[ Enable profiling

Project Ophons:

kermel32. b uzerdZ ib gdiZZ b winzpool. ib comdlg32 lib -
advapid? ib zhell 32 lib ole32.lib oleaut32 b uuid.lib
odbc32 lib odboop32 b kemel32 ik user32 ib gdi32.|ibll

o |

Cancel |

2
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4.3.4 Compiling the program

Now you should be able to compile and build your application. Click on Build button to build your
application and link it with libcurl.lib:

Build

You should see that the application compiles and MyApplication.exe file is created.

43.5 Running the program
If you try to run the application by clicking on “Run” button:

Run

%
- -

¢ T E |
You will see an error page:

ace ‘curls 1

! il ¥ISUALSTUDIOY curl',Debug curl.exe™ - | Ellll
iles
rce Files
curl.cpp

The dynaric link library LIBCURL dll could not be Found in the specified path

CHPROJECTVCURLWISUALSTUDIOcurl\Debug; . O W INNT System32 ; C W INNT syskem; C W INMT Ol appstads LO1BIN; C\Perlibind C:iPythonz 11 C
WWINNT system32; COWINNT; CAWINNTY System32) Whem; C:\Program FilesiMetwork
Associates\PGPMNT;Ciicygwinibing C:APROGR A~ 1 TCL bing i commands; i\ Program Filesietwork

Associates|PGPomding CPROGRA~1ULTRAE~1; T PROGRA~1ULTRAEDT; ;C:\Program

FilesiSTIbinpc-wings; C: digpphbing Ciijdk . 3. 1_03hin;; C:LATFE.

QK |

X

H
E
R
R
E
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Which says that the libcurl.dll could not be found in the search path. For fixing this problem you
need to put the libcurl.dll file somewhere that the application can find it. You can either put it in
C:\WINNT\System32 or C:\WINNT etc or if you don’t want to mix it with other dlI files on your
system you can put it there the EXE file of you application exist it means in :

C:\Project\libcurl\VisualStudio\MyApplication\Debug

Once you copied the dll file to one of these directories you can try again to run the application and
voila, it connects to www.cnn.com and does a GET on that site which means it reads the whole
page and print out on screen:

ROJECT'LIBCU
{stahle>

<hy width=""7?78" size="1" align=""1eft'" noshade>

<table width="778" bhorder="0" cellpadding="8" cellspacing="8"">
{tr valign="top">

<td width="128">{hr>{ td>

<td width="18">{hr>{ td>

£td width=""530">{div class="cnnCopyright"><{b>kcopy; 2082 Cahle N
ews Metwork LP, LLLP.<{/b>{br>*An AOL Time Warner Company. A1l nghtﬂ Reserved. {hy
3¢a href="/interactive _legal html">Terms<{- a> under which this service is provide
d to you.{br>*Read our <a href="/privacy.htmnl">privacy guidelines<{~a>. <a href="/

feedhack/">Contact us<s/a>.{ div><{/td>
{td width="118">{a href="http:/7ar.atwola. cum/llnk/93133339/a01"
twola.com/image 23183382 a0l1" alt="Click Here'" width=""88"
' hspace="0" vspace="B"">{ a>{ td>

widt ' height="1">
' sre="http:~sar.atwola.con/filesadsEnd. js"»<{/scr

Congratulation you made your first CURL client application. Now you can add more
functionalities and explorer CULR more with other examples.
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